Degraded Performance with Content Creation

Incident Report for Ceros

Resolved

This incident has been resolved.
Posted Apr 14, 2026 - 11:54 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 14, 2026 - 09:40 EDT

Identified

We are currently experiencing degraded performance due to ongoing issues with our CDN provider. This may result in slower load times or intermittent availability across parts of our platform.

Published content is not affected and continues to be delivered as expected.

Our team is actively monitoring the situation and working to mitigate the impact where possible. We will provide further updates as more information becomes available.
Posted Apr 14, 2026 - 08:56 EDT
This incident affected: Content Creation (Studio, Flex) and Admin (User Access, File Import, File Export).