Service Disruption Due to Downstream Provider Outage

Incident Report for Ceros

Resolved

We are continuing to monitor one issue affecting video uploads, however all other functionality is now back online.
Posted Oct 20, 2025 - 11:07 EDT

Monitoring

We're seeing recovery of our systems and are monitoring closely to ensure full functionality is restored. We'll provide further updates as we confirm full stability.

Should you have any questions about the issue or continue to experience this issue, please email support@ceros.com. Thank you for your patience as we monitored the situation and observed recovery.
Posted Oct 20, 2025 - 06:30 EDT

Investigating

We are currently investigating this issue.
Posted Oct 20, 2025 - 05:57 EDT

Identified

We are investigating reports of an issue that is caused by a downstream service provider. We apologize for any inconvenience this may have caused. Please subscribe to this status page to receive status updates via email as soon as they become available.
Posted Oct 20, 2025 - 05:50 EDT
This incident affected: Admin (File Import) and Content Creation (Flex).